0981 558668
  • Tin tức giải pháp công nghệ của CISCO
  • Cisco Solution

Hướng dẫn chi tiết các bước cấu hình giao thức VTP trên Switch Cisco

Hướng dẫn chi tiết các bước cấu hình giao thức VTP trên Cisco Switch mới nhất dành cho người sử dụng. Khi tiến hành cấu hình bắt buộc bạn phải nắm vững các kiến thức hệ thống hạ tầng mạng doanh nghiệp cơ bản.

Giới thiệu một chút về tác dụng của VTP: VTP là viết tắt của cụm từ VLAN Trunk Protocol có tác dụng duy tri cấu hình của VLAN và đồng nhất trên toàn hệ thống Network. VTP là dạng Protocol thông tin, nó sử dụng Frame Trunk Layer 2 để quản lý thêm vào hay loại bỏ cũng như đặt tên lại các VLAN trên hệ toàn bộ hệ thống etwork chỉ từ một Switch trung tâm được đặt trong Sever Mode.

VLAN Trunk Protocol hoạt động với mục đích chủ yếu là đồng nhất các thông tin VLAn trong cùng 1 vùng VTP Domain, nó giúp giảm đi các cấu hinh trùng và giống nhau trên các thiết bị chuyển mạch. Bài viết sau đây sẽ mô tả chính xác các đặc tính của Revision Number, VTP Password và VTP Domain. Để cấu hình được chúng ta sẽ cần tối thiểu 2 thiết bị Cisco Catalyst 2690 để thực hiện bài hướng dẫn này.

hướng dẫn cấu hình giao thức vtp

Cấu hình được chia sẻ trong bài hướng dẫn này sẽ là cấu hình dạng 2 switch trên cùng 1 Domain, sau đó chúng ta sẽ cấu hình VTP Password cho 2 bên khác nhau. Sau đó cổng Trunk sẽ chạy nhưng chúng vẫn chưa thấy được nhau, chúng ta sẽ tiếp tục cấu hình lần lượt các VLAN 2,3 trên switch 1 và VLAN 4 trên switch cisco 2.

Sau khi hoàn thành 2 bước cấu hình, chúng ta cùng theo dõi Switch có số Revision Numer cao hơn từ đó sẽ cấu hình lại VTP Password sao đúng nhất, sau đó switch có số Revision cao hơn sẽ tự động Update các VLAN cho switch còn lại.

Các bước tiến hành cấu hình VTP trên Cisco Switch 2960

Đầu tiên chúng ta cần show run 2 switch tương ứng với thông tin dưới đây
Switch1#show run
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch1
!
ip subnet-zero
!
interface FastEthernet0/1
shutdown
encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/4
!!!!!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
End
Switch2#show run
Building configuration...
Current configuration : 1431 bytes
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname switch2
!
ip subnet-zero
!
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
switchport access vlan 4
switchport mode access
no ip address
!
interface FastEthernet0/5
no ip address
!!!!!!!!!
interface FastEthernet0/24
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
ip http server
!
line con 0
line vty 5 15
!
end
Các bước tiến hành cấu hình
Bước 1: Cấu hình đầu tiên cho VTP Domain Name và VTP Mật khẩu
Cấu hình dành cho Switch 1
Switch1#conf terminal
Switch1(config)#vtp domain thegioimangcisco Switch1(config)#vtp password thegioimangcisco
Cấu hình dành cho Switch2
Switch2#conf terminal
Switch2(config)#vtp domain thegioimangcisco Switch2(config)#vtp password thegioimangcisco2
Bước 2: Tiến hành cấu hình Trunk
Ở bước này ta sẽ thấy 2 VTP mật khẩu của 2 switch khác nhau, nếu chúng ta cấu hình trunk ở ca2 2 đầu switch thì dù đường trunk chạy nhưng các VLAN vẫn không trao đổi thông tin với nhau được
Switch2(config)#int fa0/1
Switch2(config-if)#switchport mode trunk Switch2(config-if)#switchport mode trunk Switch2(config-if)#switchport trunk encapsulation dot1q
Vì các switch dòng 2900 series hoạt động encapsulation dot1q nên ta sẽ không cần phải đánh lệnh switchport trunk encapsulation dot1q.
Bước 3: Tiến hành cấu hình tiếp các VLAN ở 2 đầu switch, ở bước này sẽ chia thành 2 bước nhỏ đó là
1/Tạo các Vlan ( VLAN Name)
2/Gán Interface vào VLAN (Switchport Access VLAN Number )
Switch2(config)#vlan number
Switch2(config)# interface f0/n
Switch2(config-if)#switchport access vlan number
Bước 4: Kiểm tra lại thông tin VLAN bằng các lệnh: show vtp status , show vlan brief
VTP Version : 2
Configuration Revision : 1 Maximum VLANs supported locally : 64 Number of existing VLANs : 6 VTP Operating Mode : Server VTP Domain Name : thegioimangcisco VTP Pruning Mode : Disabled VTP V2 Mode : Disabled VTP Traps Generation : Disabled
Switch1#show vtp status
VTP Version : 2
Configuration Revision : 2 Maximum VLANs supported locally : 68 Number of existing VLANs : 7 VTP Operating Mode : Server VTP Domain Name : thegioimangcisco VTP Pruning Mode : Disabled VTP V2 Mode : Disabled VTP Traps Generation : Disabled
Switch2#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/23, Fa0/24
4 VLAN0004 active Fa0/4
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
Switch1#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12
2 VLAN0002 active Fa0/2
3 VLAN0003 active Fa0/3
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

Như vậy, tới bước này chúng ta đã có một Switch 1 có số Revision Number cao hơn, khi đường Trunk hoạt động switch 1 sẽ Update VLAN 2,3 cho Switch 2 và VLAN 4 ở swtich 2 sẽ biến mất. Từ đó chúng ta có thể thấy tầm quan trọng của VTP Password, nó giúp chống các switch lạ khi cắm vào hệ thống sẽ gây xáo trộn các VLAN. Giờ đây chúng ta sẽ tiếp hành cấu hình VTP Passwor thegioimangcisco và bật debun sw-VLAN VTP event trên switch 2

Switch2#debug sw-vlan vtp event

vtp events debugging is on

Switch2(config)#vtp pass thietbimangcisco

Setting device VLAN database password to thietbimangcisco

Switch2#write

Copy completed.

Bây giờ chúng ta xem lại các vlan của Switch2, Switch có revision number bé hơn .

Switch2#show vtp vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/2, Fa0/3, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
2 VLAN0002 active
3 VLAN0003 active

Như vậy Vlan 4 không còn Switch2 , lúc này ta dùng lệnh show vtp status .

Switch2# show vtp status

VTP Version : 2
Configuration Revision : 2
Maximum VLANs supported locally : 64
Number of existing VLANs : 7
VTP Operating Mode : Server
VTP Domain Name : thegioimangcisco
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
Local updater ID is 0.0.0.0 (no valid interface found)

Ta thấy số revision number lúc này của Switch2 bằng 2, bằng với số của Switch1

Trên đây là toàn bộ hướng dẫn chi tiết các bước để người quản lý hệ thống có thể cấu hình gaio thức VTP trên Switch Cisco. Bài viết hướng dẫn chi tiết các bước và dòng lệnh trả về trên màn hình hiển thị khi cấu hình, thietbimangcisco hy vọng sau khi tham khảo xong khách hàng có thể hình dung và thao tác thành công.

Các tin khác
Thông tin liên hệ
Hà Nội: 024.22255666
Hồ Chí Minh: 028.62959919
Số di động: 0981 558 668
thegioicisco@gmail.com

Video

0981 558 668

0981558668